Activa conexiones seguras a tu tienda Shopify
Activar las conexiones seguras a tu tienda Shopify garantiza que los datos que ingresan tus clientes permanezcan privados y seguros. Esto se logra usando un certificado TLS (Seguridad de capa de transporte), a veces conocido como certificado SSL (Capa de puertos seguros), que cifra la comunicación entre tu tienda y el contenido externo, y publica el contenido de forma segura usando HTTPS en lugar de HTTP.
Por ejemplo, si la URL de tu tienda eshttp://www.example.com
, la URL se cambia ahttps://www.example.com
cuando se emite el certificado TLS. Si tus clientes usan la URL original, se redirigen automáticamente a la tienda online encriptada.
Los certificados TLS ofrecen las siguientes ventajas para tu tienda online:
- Agregan un nivel de seguridad al cifrar los datos de los clientes.
- Ayudan a generar la confianza de tus clientes al mostrar un ícono de candado junto a la URL de tu tienda online.
Adquirir un certificado TLS
Los certificados TLS se entregan gratis a todos los dominios que se agregan a Shopify. Un certificado TLS se emite automáticamente en las siguientes circunstancias:
- Para cualquier activo alojado en el dominio
.myshopify.com
. - Cuandocompras un dominio personalizado a través de Shopifyotransfieres un dominio a Shopify.
- Cuandoconectas tu dominio externo a Shopifycambiando tu registro A y tu registro CNAME para que dirijan a Shopify. En este caso, la emisión del certificado TLS puede tardar hasta 48 horas. Durante dicho período, es posible que aparezca un error deSSL no disponibleen tu panel de control de Shopify. También puede mostrarse un error de seguridad en tu navegador cuando los clientes visiten tu tienda online. Si aún aparece un error de seguridad en tu tienda después de más de 48 horas, comunícate con el equipo deatención al cliente de Shopify.
Puedes asegurarte de que se haya emitido tu certificado TLS verificando que el estado del dominio es连接
en la páginaDominios. Además, el ícono del candado se muestra junto a la URL de tu tienda online en la barra de direcciones cuando ves tu tienda online.
Verificar que tus recursos son seguros
Si tu tienda online incluye imágenes, videos, fuentes web u otros recursos alojados en otro sitio fuera de Shopify, debes mostrarlos a través de HTTPS. Cualquier página de tu tienda online de Shopify que incluya un activo que no se muestre a través de HTTPS se considera no segura.
La mejor opción para garantizar la seguridad de tus recursos es alojar todos los recursos de tu tienda online en Shopify.
Si necesitas alojar tus recursos fuera de Shopify, asegúrate de hacer lo siguiente:
- Aloja tus recursos en un servidor que publique a través de HTTPS.Obtén más información sobre cómo subir archivos al panel de control de Shopify.
- Aloja tu contenido de videos en un servicio que publique a través de HTTPS.
- Cuando utilices fuentes web, verifica que se publiquen a través de HTTPS desde su origen.
Registros de la Autorización de la autoridad de certificación (AAC)
Se emplea un registro de Autorización de la Autoridad de Certificación (AAC) para especificar qué autoridades de certificación tienen potestad para conceder certificados para un dominio. Una autoridad de certificación (AC) es una entidad consolidada que concede documentos electrónicos cuyo fin es verificar la identidad de una entidad digital en internet
No necesitas registros de AAC para tu tienda. Sin embargo, si necesitas usar los registros de AAC, se deben agregar las siguientes autoridades de certificación (AC) a cada registro de AAC al mismo tiempo queconectas tu dominio a Shopify:
Resolución de problemas de seguridad para tu dominio externo
Después de conectar tu dominio externo a Shopify, tus clientes no pueden acceder a tu tienda online.
Síntoma
Se han producido los siguientes errores:
- En tu panel de control de Shopify se muestra un error de TLS o SSL no disponible.
- Un mensaje similar a
Your connection is unsecure
se muestra en tu tienda online.
Causa
El certificado TLS puede tardar hasta 48 horas en emitirse después de conectar tu dominio externo a Shopify. Durante ese tiempo, es posible que aparezca un error de TLS o SSL no disponible en tu panel de control de Shopify. Si el error persiste después de 48 horas, es posible que el sitio de tu proveedor de dominios no se configure correctamente.
Resolución
Si el error de TLS o SSL no disponible se sigue mostrando después de 48 horas, haz lo siguiente:
- Verifica que tu registro A sea
23.227.38.65
y tu registro CNAME seashops.myshopify.com
. - Si usasregistros de AAC,verifica que has agregado todas las autoridades de certificación necesarias.
- Si usas un registro AAAA, elimínalo.
- Si tienes habilitado DNSSEC para tu dominio, desactívalo.
Si necesitas más ayuda, comunícate conatención al cliente de Shopify.